首页  >   经验  >   VS2017如何同时支持Python3.6和2.7版本的环境

VS2017如何同时支持Python3.6和2.7版本的环境

codexia 2017-10-04 00:08:29 3381
VS   2017   python3.6   python2.7  
手机阅读 | 转发赚积分
手机收藏 | 分享给好友
简介Win10中如何安装python2.7环境,如何在VS2017中安装Python2.7环境,如何在VS2017中切换python的版本即VS2017切换Python环境??这些问题,本文都做了详细的解答了。
感谢 阿里云 对本站(本站由阿里云高性能服务器搭建)的赞助支持,本站推荐 →高性能云服务器2折起优惠由此进←↓
高性能云服务器2折起
秒后广告自动消失...会员无广告。点击可关闭广告。
    在公司的电脑的VS2017的环境里,都已经配置好了VS2017的python的2.7和3.6的版本。一开始就因为这个环境问题,提示Python语法报错。后来切回正确的版本,就OK了。
    今天在自己的电脑里打开VS2017,然后发现莫名其妙的报错。然后仔细一看,原来我是按照python2.7来写的语句,然后3.6报错,即print后面直接空格后就输出变量的值,而python3.6需要加括号。
    之前在公司配置过python2.7的环境的,然后因为比较匆忙,也就没有做笔记,然后今天突然懵逼了。所以,还是写个总结,记录一下。
    在VS2017的在线安装程序的安装选项中,我们可以勾选python模块,也就是会安装python。然而,默认的情况如下图所示:
    
关注左侧公众号
发送 07eZT@P01
复制文章阅读码
填到下面输入框并确定
看完整内容
标注
评论
站内搜
百度搜
传送到手机
手机扫码,识别文字,完成传送x
加载中...
标注内容x
加载中...
添加标注x
文章标题:VS2017如何同时支持Python3.6和2.7版本的环境
文章地址:http://py.w3tong.com/article/20171040829346
转载到个人博客,请在文末带上右侧内容(含超链接):本文转载自:VS2017如何同时支持Python3.6和2.7版本的环境
收藏 0 点赞 0
公众号
微信赞赏
支付宝赞赏
领支付宝大红包
QQ群

相关阅读

  1. VS2017实现python的web服务同时监听多个端口调试的方法 查找全网同类文章
  2. 分析解决Python2.7的webpy的querystring乱码的问题 查找全网同类文章
  3. 宇宙最强IDE-VS2017对python支持情况简评 查找全网同类文章
  4. VS2017中可视化创建并使用python虚拟环境 查找全网同类文章
  5. VS2017如何同时支持Python3.6和2.7版本的环境 查找全网同类文章
  6. VS Code配置python初体验笔记 查找全网同类文章
  7. python2.7运行错误:无法加载共享库libpython2.7.so.1.0 查找全网同类文章
  8. VS下所有版本Python插件合集下载(2010、2012、2013、2015) 查找全网同类文章
  9. python3.6 lxml标准库lxml的安装及etree的使用注意 查找全网同类文章
  10. python找不到模块No module named和模块的函数的解决办法 查找全网同类文章
分享到:

相关阅读

猜您感兴趣